EzDevInfo.com

wireless-bridge interview questions

Top wireless-bridge frequently asked interview questions

OpenWRT - Guest Wi-Fi on bridged client

I have a spare WRT160NL which I configured as bridged client, mainly following this guide. Main Routers IP is 192.168.178.1 which also connects to the internet. WRT's IP is 192.168.178.2, this device is connected to the main router via wi-fi in client mode. The same SSID is then broadcasted in AP mode ("Mode: Master") and DHCP on the WRT is disabled. A bridge interface connects the "wireless wan" and the wireless net on the WRT.

Problem

Now I would like to configure a guest wi-fi but can't seem to get it working. I'm following this guide. The new guest net is broadcasted and I can connect to it and also get an IP with DHCP. In a first step I tried to ping WRT's interface address of this net which is 192.168.3.1. This fails and I can't figure out why. Before trying anything else, tweaking firewall settings and so on I should be able to ping the routers IP from inside the subnet, shouldn't I? Since I have a bridge interface ("stabridge") I added the guest interface to the bridge interface which also did not work.

Config files

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option gateway '192.168.178.1'
    option dns '192.168.178.1'
    option delegate '0'
    option ipaddr '192.168.178.3'

config interface 'wwan'
    option proto 'static'
    option netmask '255.255.255.0'
    option gateway '192.168.178.1'
    option delegate '0'
    option ipaddr '192.168.178.2'

config interface 'stabridge'
    option proto 'relay'
    option ipaddr '192.168.178.2'
    option delegate '0'
    list network 'guest'
    list network 'lan'
    list network 'wwan'

config interface 'guest'
    option proto 'static'
    option ipaddr '192.168.3.1'
    option netmask '255.255.255.0'
    option delegate '0'

/etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ath9k'
    option htmode 'HT20'
    option disabled '0'
    option channel '4'
    option txpower '21'
    option country 'US'

config wifi-iface
    option network 'wwan'
    option ssid 'wi-fi'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid '24:65:11:XX:XX:XX'
    option key 'wifipassword'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'wi-fi'
    option network 'lan'
    option encryption 'psk2'
    option key 'wifipassword'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option network 'guest'
    option ssid 'wifi_guest'
    option encryption 'psk2'
    option key 'wifiguestpassword'

/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan wwan'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wan6 wireless_open'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config rule
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config zone
    option name 'guest'
    option input 'ACCEPT'
    option forward 'REJECT'
    option output 'ACCEPT'
    option network 'guest'

config forwarding
    option dest 'wan'
    option src 'guest'

config rule
    option target 'ACCEPT'
    option src 'guest'
    option proto 'tcp udp'
    option dest_port '53'
    option name 'Guest DNS'

config rule
    option enabled '1'
    option target 'ACCEPT'
    option src 'guest'
    option proto 'udp'
    option dest_port '67-68'
    option name 'Guest DHCP'

Bonus Points: I tried to configure the exact same setup with DD-WRT which also failed, I also could not ping the gateway from inside the guest net. Am I hitting some hardware limitation here?

What steps am I missing to configure the guest net to use "wwan" for connecting to the internet? Thanks for looking!

config

Firewall settings: Firewall

Stabridge

Removed guest net from bridge if, still can't ping guest gateway from inside guest net.

root@OpenWrt:~# ifconfig 
br-lan    Link encap:Ethernet  HWaddr BE:0F:EC:XX:XX:XX  
          inet addr:192.168.178.3  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fe80::bc0f:ecff:fe6f:f226/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6944791 errors:0 dropped:4991 overruns:0 frame:0
          TX packets:11086842 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:581010664 (554.0 MiB)  TX bytes:15224175749 (14.1 GiB)

eth0      Link encap:Ethernet  HWaddr BE:0F:EC:XX:XX:XX  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:291345 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:18850062 (17.9 MiB)
          Interrupt:4 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:149 errors:0 dropped:0 overruns:0 frame:0
          TX packets:149 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10372 (10.1 KiB)  TX bytes:10372 (10.1 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:03:7F:XX:XX:XX  
          inet addr:192.168.178.2  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fe80::203:7fff:fec0:7cfa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10984215 errors:0 dropped:2 overruns:0 frame:0
          TX packets:7134194 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2342342874 (2.1 GiB)  TX bytes:830422933 (791.9 MiB)

wlan0-1   Link encap:Ethernet  HWaddr 02:03:7F:XX:XX:XX  
          inet6 addr: fe80::3:7fff:fec0:7cfa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6989301 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11120218 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:714322711 (681.2 MiB)  TX bytes:2590755125 (2.4 GiB)

wlan0-2   Link encap:Ethernet  HWaddr 06:03:7F:XX:XX:XX  
          inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
          inet6 addr: fe80::403:7fff:fec0:7cfa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:955 errors:0 dropped:6 overruns:0 frame:0
          TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:90423 (88.3 KiB)  TX bytes:47057 (45.9 KiB)

root@OpenWrt:~# ifdown br-lan
Interface br-lan not found
root@OpenWrt:~# ifdown eth0
Interface eth0 not found
root@OpenWrt:~# ifdown wlan0
Interface wlan0 not found
root@OpenWrt:~# ifdown wlan0-1
Interface wlan0-1 not found
root@OpenWrt:~# ifdown wlan0-2
Interface wlan0-2 not found

Source: (StackOverflow)

How to fix a Sitecom WL-330 wireless range extender 300N that stops repeating, even after a device reset?

After having setup a Sitecom 300N wireless range extender (WL-330 v1 002) it suddenly stopped working after months of usage.

Even after powering the device off and back on again, and after re-applying its settings, the wireless repeater doesn't want to repeat the wireless signal again.

How to fix this?


Source: (StackOverflow)

Advertisements

how to set bridge interface in eth0 and ath0

I'm developing openWRT SDK AA version. How do I set bridge interface between ethernet and wireless interface? Can I create extra interface, say A besides those existing WAN and LAN and then bridge interface A and LAN tog


Source: (StackOverflow)

Is there a wifi to ethernet adapter?

I would like to get a TiVo Mini, but bafflingly it does not seem to support WiFi. I don't have cable or ethernet in the room I wish to use it in, and it seems like it must be on the same subnet as the TiVo or I could possibly use a wireless extender. Is there any device that will let me connect to my WiFi and provide a bridge to connect to the Mini's ethernet port so that it would be on the same subnet as my TiVo?


Source: (StackOverflow)

Is it possible to have multiple repeaters in a network with just 1 uniform SSID?

I'm currently setting up a network with 1 access point. Since WiFi range is not very far, I'd like to extend the range by using repeaters. I did several setups in the past but they always had another SSID. So I had an SSID for my repeater which computers and devices could connect to, and the repeater connects to the main access point.

Is it possible to have a router with a name 'linksys' and 3 repeaters connected to it? Would it be possible to have all repeaters to have the name 'linksys' so only 1 SSID would appear in the networks detected? Is there any other option to this if it's impossible to do with repeaters?


Source: (StackOverflow)

Does a wireless repeater slow things down for everyone?

I recently moved into a new apartment, and we've found that the wireless connection we've set up isn't accessible in all rooms. I'm thinking about buying a new router and running it as a repeater in bridge mode.

I've heard that running a repeater slows things down for computers using it. What I'm not sure of, though, is if it will slow down connections for everyone in the house. Will I still experience a slower connection speed when I am within range of the original wireless router?


Source: (StackOverflow)

What's the best way to extend wifi over a wired network?

I've got primary router that handles the connection out to the internet, acts as a switch and broadcasts a fairly weak wifi signal. This is connected to a decent 200Mbps powerline adapter which comes out in another part of the house. The far end of the powerline adapter connects to a 5-port gigabit switch.

The problem is that the wifi signal is terrible in the room that has the gigabit switch, so I'm looking to get something to improve the signal. Ideally, this something would have the same SSID and setup as the main wifi router, so that wireless devices in my home can just connect to whichever is closest seamlessly.

From the research I've done, it seems I want some kind of repeater, but from what I've read most repeaters just use the weak wireless signal they can pick up and rebroadcast it stronger. I'd guess that I'd get a faster and more reliable connection if I could somehow make use of powerline adapter and switch set-up for this, rather than eventually ultimately routing through the weak wifi signal.

The current switch has a single ethernet port free to connect another device. What device(s) should I connect? I'm happy to either put something in the free ethernet slot purely to improve the wifi signal, or I'm happy to replace the entire switch (I'd still need at least 4 ports).


Source: (StackOverflow)

Can I use a Netgear WNR2000 v2 as a Wireless Bridge?

I'd like to connect my WNR2000 to my existing wireless network and then connect wired devices to the bridge. Is this possible? How would I set it up?


Source: (StackOverflow)

Hardware needed to route between two networks over wireless

I recently rented an apartment about 100 yards from my brother's house. I have line of sight to his house and can pick up his home AP signal with one of my two laptops if I go out on my balcony (facing his house) or put the laptop by the window. The other laptop will sometimes see the SSID broadcast, but fails to connect, drops, etc.

We would like to set up a persistent wireless connection between our homes. We would prefer each network be logically segmented as independent networks, but he will share his internet connection. I've got a bunch of tv shows saved to a NAS by my TiVO that I'd like to make available to him across the wireless link. My brother strongly prefers to not mess with his WAP at all. His network is running fine and is afraid to mess it up. I guess you could say he is "technologically declined". If we can get a reliable 11Mbps connection we will be satisfied.

What hardware do I need to make this work? I was thinking a router with two wireless interfaces (external antennas) a wired interface, and a directional antenna mounted on my balcony facing his house.

Can anyone recommend hardware to make this happen? Cheaper is better. I'll only be living in the area a year or two. I do have an old satellite TV antenna if that can be used to direct the signal.


Source: (StackOverflow)

second router: access point vs. bridge mode

I have my main router running Tomato. My second router is configured as an access point using a different channel as the main router, but the same SSID/WPA2 info. All the firewall stuff, plus DHCP is turned off. It is connected WIRED to the first router using one of the LAN ports and is on the same IP range. Things are working fine and clients can connect to either one, though the main one is N while the second one is G.

I was reading about Wireless Ethernet bridge mode recently. I was thinking of replacing the second router with another N router that can run Tomato. But only if bridge mode gives me something I can't do now. Is there any advantage to using bridge mode?


Source: (StackOverflow)

Bridge Hosted Network with another network

I create a hostednetwork in windows 8-1.

after that i select the new virtual wifi and ethernet but there is no option to making bridge.

I have this problem because of the windows 8.1 did not support ad hoc network:(

I create a hostednetwork with the below command

netsh wlan set hostednetwork mode=allow ssid=sam key=qwert12345 keyusage=persistent
netsh wlan start hostednetwork 

Source: (StackOverflow)

Wireless PCI Card vs Wireless Bridge?

I'm having trouble finding a good Wireless PCI Card that works with Windows 7 x64 and Vista x64.

Does anyone have any experience with using a Wireless Bridge to connect a wired device to a wireless network? How does it compare to using a Wireless PCI Card instead?


Source: (StackOverflow)

Using my PC as a wireless bridge

I'm not sure how to go about this; hence the question.

My home office is placed so that ethernet is not practical from my router. I have a PC that is always on in that office and it connects to my n router with an n card.

I have a gigabit switch, NAS and a network printer.

I would like to connect my switch to the ethernet port on my PC and allow any device plugged into that switch to be on the same network as the rest of the computers/devices on my wireless network.

Is this possible, or do I need to buy wireless bridge?

If it is possible, a straight-forward how-to would be much appreciated. Please specify if I need to run an ethernet cable or a cross-over cable from my PC to my switch as well.

Cheers!


Source: (StackOverflow)

Can I use the second band in my dual-band router as an AP with the first band being in "client mode"? (dd-WRT)

I couldn't register to dd-WRT forum because the registration code is case sensitive and I don't have the same case "looks" in my country as they had in their website... So, the second place of choice was here :).

Situation: I'm getting my WAN from another router by using one wireless "band", which is in "client mode". I have a dual-band router.

What I want: I want my second band to work in AP and resend the connection being obtained by that same WAN. (Using same DHCP server as well). When I put it in AP, it transmits the signal but I the DHCP doesn't work for it.


Source: (StackOverflow)

Putting my computer in another room for noise

Why? I'm not getting any younger, and the older I get, the more sensitive my ears become. Right now, if I don't sleep with ear-plugs, I get migraines the next day. I used to be a game enthusiast, so I have a very power gaming computer. I don't play often now, but when I play, I always finish playing with tinnitus due to my graphics cards and CPU cooler. I invested lots of money to make it silent, but no matter how much I spend, I still am sensitive to its noise.

Breaking it down: So I figured that to do this, there are multiple things I have to manage on long distance:

  1. Ethernet: This is easy because I could move my Router. That's not a problem.

  2. HDMI: I found this on amazon, so I'm gonna buy it.

  3. 5.1 Sound system: I found this on amazon, so I'm gonna buy a few of these for every connector.

  4. USB ports (many 2.0, and maybe one ore two 3.0 occasionally): This is my problem now.

So my question(s) is/are: How can I solve the USB problem? Do you know of any solutions? I'm afraid of response latencies of my keyboard and mouse. Also what are possible issues I may run into?


Source: (StackOverflow)