EzDevInfo.com

bgp interview questions

Top bgp frequently asked interview questions

What does BGP Path Attribute Type 18 refer to?

Does anyone know what Path Attribute Type 18 refers to and how to parse it? The best I can understand is that it is a new AGGREGATOR (type 7) and I'm assuming that it's reading the new AS32 format, but that's not cutting it because I can't parse this packet. Is there an RFC that describes how this works...is it something special that CISCO or another network vendor introduced?


Source: (StackOverflow)

Can we assign link local address as BGP peering address on VPN gateway with BGp enabled on azure?

It seems like azure assigns the second last address from CIDR block used in GatewaySubnet as the BGPPeeringAddress for VON gateway with BGP enabled. Can we change that to use link local address? Something like 169.254.0.2?


Source: (StackOverflow)

Advertisements

Configuring BGP using Azure portal

Does Azure web portal support configuration of BGP on VPN gateways? All online documentation seems to contain steps using powershell. But powershell doesn't work with linux machine. Am I correct? So, does only way to conifgure BGP on VPN gateways on azure is via powershell commands on windows machine?


Source: (StackOverflow)

Computer Networking - BGP

Consider the network shown above. Suppose all ASs are running OSPF for their intra-AS routing protocol, with the cost of each link equal to 1. Suppose eBGP and iBGP are used for the inter-AS routing protocol. Initially suppose there is no physical link between AS2 and AS4.

enter image description here

Routers(1a,1b,1c,1d,2a,2b,2c,3a,3b,3c,4a,4b,4c) learns about prefix x from which routing protocol: OSPF, RIP, eBGP or iBGP?

I'm so confused on BGP, I think the answers should be either eBGP or iBGP. Can anyone help me with this and explain why? (I think 1c and 3c should be eBGP, and 3a and 1d should be iBGP. Not sure about others)


Source: (StackOverflow)

redistribute BGP routes in OSPF

Consider two routers A & B. Both of them run eBGP for connecting to ISP and also run OSPF inside the cloud. Both A&B also run iBGP and are connected in an internal iBGP mesh.

How suppose prefix P1 is received at both A & B (eBGP). They run the bgp process as:

router bgp 747
neighbor xxxx route-map ISP-ROUTES-IN

route-map ISP-ROUTES-IN permit 100
match ip address prefix-list ACCEPT-ROUTES-FROM-ISP
ip prefix-list ACCEPT-ROUTES-FROM-ISP seq 10 permit xx.xx.xx.xx/29

In both A&B, inside the OSPF process there is a redistribute statement like:

router ospf 1234
redistribute bgp 747 metric-type 1 subnets tag 747

Because of the ospf process 1234, both routers A & B redistribute P1 inside their network as Type5 E1.

However, I would like to make A as the exit point for prefix P1 and B as the backup exit router.

How do I set the metric for redistribution?


Source: (StackOverflow)

How to set up BGP on Juniper SRX220?

I have two ports:

  1. LAN (1.1.1.1/24)
  2. Internet Upstream (2.2.2.2/30)

The router should announce the LAN prefix 1.2.3.0/24. All traffic should be send to 2.2.2.1 (Upstream).

Our AS is: 1, Upstream AS is: 2

Does the following configuration fits the requirements?

 interfaces {
     ge-0/0/0 {
         unit 0 {
             family inet {
                 address 1.1.1.1/24;
             }
         }
     }
     ge-0/0/1 {
         unit 0 {
             family inet {
                 address 2.2.2.2/30;
             }
         }
     }
 }
 routing-options {
     static {
         route 0.0.0.0/0 next-hop 2.2.2.1;
     }
     router-id 1.1.1.1;
     autonomous-system 1;
 }
 protocols {
     bgp {
         group as2 {
             peer-as 2;
             neighbor 2.2.2.1;
         }
     }
     stp;
 }

Source: (StackOverflow)

How to remove the authorization set by TCP_MD5SIG in setsockopt - C, Linux?

I have used TCP_MD5SIG to create password/key for the connection using the API - setsockopt() in C, Linux. This works fine for me. However, when I use it to remove the password/disable authorization with the same API except that the

struct_tcp_md5sig.tcm_Key = 0;
struc tcp_md5sig.tcm_keylen = 0;

I see that when I invoke the same API -

rc = setsockopt(sock_fd, IPPROTO_TCP, TCP_MD5SIG, &md5sig, sizeof(md5sig));

I see that the rc is -1. The strerror says that "no such file or directory".

I am confused on what I should do to disable the authorization. The same API works, when I pass the password. On the other hand, the same API doesn't work when I want to disable the authorization. I have enabled this protocol in the kernel. So, there is no issue with enabling of this feature in kernel.


Source: (StackOverflow)

Understanding BGP routing

AS number 144 has two border routers BR1 and BR2. BR1 peers with AS 555. BR2 peers with AS 1977. Assuming that BR2 decides to advertise a route to the prefix 128.15.0.0/16, which of the following are valid route advertisements? AS 144 may have received advertisements from other ASes but received no other advertisements for that prefix from AS 555. Check all that are valid.

1) 128.15.0.0/16 6294 144
2) 128.15.0.0/16 555 144
3) 128.15.0.0/16 78 11101 6294 555
4) 128.15.0.0/16 78 11101 6294 555 144
5) 128.15.0.0/16 78 11101 6294 555
6) 128.15.0.0/16 78 11101 6294 555 555 144 144
7) 128.15.0.0/16 78 78 144 144
8) 128.15.0.0/16 64393 144 144

I know that 3 equal to 5. Also previous question contain this:
BR1 receives a route advertisement from AS 555 for prefix 128.15.0.0/16, with path 78 11101 6294 555 555. The double listing of 555 is correct; it’s a way for 555 to make the path seem “longer.”

I've searched for AS_PATH examples but still don't understand this question: if I understand correctly network 128.15.0.0/16 in AS 555 as path is ended with 555. But why doesn't it have 144 in its beginning.


Source: (StackOverflow)

Handle bgp protocol packet size

Why BGP protocol restict its packet size less than 4096 octet?

If the BGP packet size exceeds 4096 bytes,how should I handle this?


Source: (StackOverflow)

How to look at BGP's LOC-RIB using Quagga library

While reading the documentation, I saw that, "You can use Quagga library as your program’s client user interface". Basically, I want to look at BGP's LOC-RIB (RIB = Routing Information Base) that Quagga constructs, with my C program (in Ubuntu/ FreeBSD).

I have just started using Quagga and I want to know how to do this using Quagga library (or maybe by using the *.h files that quagga provides).

Can any one help me with suggestions, tutorials or links?

Bye.


Source: (StackOverflow)

BGP use of looking glass

What are the uses of a looking glass server to BGP protocol?

What specifically does BGP look up on a looking glass server during path selection? Is is looking up the rest of the path-- beyond what it sees on on the path vector delivered to it?

Maybe a naive Q-- however i couldn't make much out of it.

TIA


Source: (StackOverflow)

Dynamic Routing with Quagga routers

I am a newbie to quagga routers. Can someone please help me in simulating dynamic routing protocol (preferably BGP) inter-office connectivity? Which software is recommended to simulate this with a Linux virtualization solution? - Any pointers would be greatly appreciated.


Source: (StackOverflow)

Cannot read compressed bz2 file from http://archive.routeviews.org/

For class we are to download these 54MB .bz2 files from routeviews.

When I unzip the .bz2 files they are in .0000 format and around 500MB. When I -tail -f the output its a bunch of garbage.

How can I convert these data to ascii so I can start working with it?

This is what I get when I tail the file: �xx��1'1/�1/�1/�1/�1N 1��1��w@����'R��+S@P R��2%@P-�+�1��w@7R���!@P1��w@P[�>"R���%@P�1��w@�>��-R���!@P1��w@����R���,@PX|5���+R�
Source: (StackOverflow)

How do I test precision timer support for BGP?

I wanted to know how can I implement(thinking of the most basic scenario) and know the working of precision-timer of BGP ?


Source: (StackOverflow)

What's the meaning of BGP prefix?

Through this website IP to ASN lookup,I can get a series of results about the ASN,but I can't find the meaning of BGP prefix.Maybe I know what it is,however,how it works?

Is there anyone who can tell me the role BGP prefix plays in the ASN system?


Source: (StackOverflow)